Local Speckle Server - Importing a file not working

So, I already have a local speckle server running on my local windows 10 machine (some context can be found here Windows 10 machine - Installing Speckle Server).

I tried to upload an ifc file to a stream but the file is not uploaded to the server.

Logs of Speckle Server can be found here:

My docker compose YML file:
docker-compose-alberto-v3.yml (4.1 KB)

Note: for the front-end, I am using Docker hub image. As I said in this topic (Windows 10 machine - Installing Speckle Server), for some unknow reason, if I used the front-end from git, the container is constantly restarting and I have this error:

standard_init_linux.go:228: exec user process caused: no such file or directory


Hi @BenHur , thanks for reaching out again.

The standard_init_linux issue appears to probably be caused by line endings on the init script. I will look into whether this can be resolved. (I’ve created an issue in our tracker)

Regarding the file import problem; would you be able to share the output of docker ps, which shows the running containers and docker log [container name of fileimport-service]?

1 Like

Hello @iainsproat,
I will send next, the logs related to importing ifc file.

Yes, it seems there is an issue in your speckle-frontend.

If I do git clone GitHub - specklesystems/speckle-server: The Speckle Server, Frontend, 3D Viewer, & other JS utilities. and then run your YML file, the front end will not start.

I noted that also in your Docker Hub images. If I try with this speckle-front end image “2.7.2-alpha.5973” I have this issue. But this version “speckle/speckle-frontend:2.7.2-alpha.5411” does not have this issue.

Also, I tried with this release 2.7.1, I download your source code (Release 2.7.1 · specklesystems/speckle-server · GitHub). Now using your YML file, the front end docker container starts.

I noted that this release 2.7.1 source code, does not contain the data for the dependencies (redis, postgres, etc). Where I can find this data that is compatible with this version 2.7.1? When I start speckle-server I have this migration error’s:

2022-08-12T08:13:49.994Z speckle:www Error: The migration directory is corrupt, the following files are missing: 20220803104832_ts_test.js

at validateMigrationList (/speckle-server/node_modules/knex/lib/migrations/migrate/Migrator.js:566:11)

at Migrator.latest (/speckle-server/node_modules/knex/lib/migrations/migrate/Migrator.js:69:7)

at processTicksAndRejections (node:internal/process/task_queues:96:5)

at async exports.init (/speckle-server/packages/server/app.js:98:3)

It seems there are missing files here, …\speckle-server-2.7.1\speckle-server-2.7.1\packages\server\modules\core\migrations, I do not find the file 20220803104832_ts_test.js.


Hello @iainsproat,
regarding running the front-end, I have found an workaround.

On a windows 10 machine, using Visual Studio Code, open the following file in the editor and change the endings from CRLF to LF.

File location:

Regarding the issue when importing an IFC file, I tried to upload this file:

You find the log for docker ps here:
dockerPs.txt (2.0 KB)

The log for the importing service here:
fileImportLog.txt (32 Bytes)

The log for the front end here (I have uploaded the file at 11:39 am):
frontEndLog.txt (30.1 KB)


1 Like