I need help with several errors in Revit

I want to convert line data from grasshopper into revit. For this I used the data for the elevations from revit, which are in (mm) and used it as floor heights in rhino/grasshopper and when converting to RevitElements in grasshopper Speckle, i used the same data of the levels. I keep getting this error however. I also used the families and types from the revit file but it doesnt recognize this. My rhino file is in (m).


Can’t obtain permission to edit the element: The Central Model is inaccessible. You can check out worksets at risk, but consider carefully!
Objects failed to bake due to a fatal error!
This is likely due to scaling issues - please ensure you’ve set the correct units on your objects or remove any invalid objects.

Revit error: Can’t obtain permission to edit the element: The Central Model is inaccessible. You can check out worksets at risk, but consider carefully!

1 Like

Hey @Adrian_2.0 welcome to the forum and thanks for reporting this issue!

Would you be able to share your script and/or some of the source files for us to test on our end?
There seem to be quite a few errors, so that’d help us a lot in understanding what’s happening :slight_smile:

StructuralModelSpeckleToRevit_Adrian.gh (121.9 KB)

Here is the grasshopper file in which i tried to export the grasshopper data into revit objects, unfortunately when I load it into Revit, my Revit crashes. I internalized all of the data in the grasshopper file, so it should work when opened in rhino.

1 Like

Thanks for sharing @Adrian_2.0 !

I just tested with the first tower and it sent fine without warnings :dizzy:, while we do further tests, can you please confirm you have the latest version of the GH and Revit connectors?

Could you also try receiving in a new Revit project that has worksharing disabled? It could be that the errors are due to worksharing permissions.

I changed some stuff in the file, apparently not for each tower the levels and geometries were grafted in the same way, which caused issues. I can confirm that I have the latest connectors for Revit and GH installed. Another thing is the worksharing, apparently that is the file that’s causing the problem. I tried exporting it in a new Revit file and got each of the towers working. So I think it is just some issue with the workshared Revit file, I can work arround that.

Another thing I was wondering about, is whether there’s an option to decide the orientation of the columns placed in Revit. Since in GH the geometry you assign is just a line, Revit then automatically makes the ‘Column’ aligned with the xyz axes from Rhino. So the towers which have a different orientation, have columns which are incorrect. The image added kind of shows what I mean, with the red squares being the columns that align incorrectly and the green columns showing how it should be in Revit.

Awesome, glad to hear it’s working now!
In regards to worksharing, maybe the problem is the creation of levels? Not sure as Speckle does not actively do anything there, but let us know if you find something out.

Regarding columns, would it be an option to use the Vertical ones? They do have an input parameter for rotation. Slanted columns in theory already have their “slated baseline” defining the rotation… But again, let us know if that’s not the case and we case and we can look into adding it too!