Grasshopper to Revit - Broken Geometry

Good day,

I’m relatively new to Speckle but I am encountering something odd.

I create geometry in Grasshopper (breps) and send it through speckle as DirectShape by base geometries to Revit.

In my Rhino (see below) all geometry comes in smooth and “healthy”

Once it hits speckle and finally Revit the geometry becomes jagged and broken:

Looking at the speckle stream online it looks like the jagged edges are already coming in when it hits Speckle. Has anyone ecountered something like this? I’m curious if it might be the translation, geometric working ranges (since the model it is loaded into is quite large) or improper usage of the converter

Hey @RamiEvans ,

Welcome to the community! Feel free to Introduce yourself :person_gesturing_ok: to the community if you want to! :smiley:

Looks like these breps are converted into meshes. We recently made improvements on how we handle Breps. What version of Revit connector are you using? Can you share the commit or add me ( as a collaborator so we can better investigate.


@gokermu Thank you! I have added you to the stream - I am using Revit connector 2.6.4

I can’t seem to reproduce this. Can you upgrade to 2.6.5 and try again?

PS. You can create Direct Shapes in Railings category directly from Grasshopper too.

1 Like

As for the “broken” behaviour you specify, and how the solids seem to also be “tesselated” in the viewer:

When you send a Brep to Speckle, 2 things happen:

  • we preserve the native Brep information so that platforms that understand Brep/Solids can receive them as such.
  • we convert it into a Mesh that will be used in any platform that does not support Brep/Solids.

Since support between platform varies, it is possible to send some BREPs from Rhino that will be:

  1. Perfectly received in Rhino as BREPs
  2. Fail to receive in Revit, in which case we will use the Mesh that was generated upon sending.

This allows us to always be able to “display something”, and it’s the default behaviour for platforms like Unity, Unreal and our 3D viewer, where Solids are not supported, but Meshes are.

As @gokermu said, we recently implemented some changes to make this issues better in Revit, but there will always be some solids that are not compatible with Revit at all, and for those having the tesselated mesh is the only option possible.

Hope that brought some light on to what is happening on the background when using Speckle :wink:

1 Like

Good day @Gokermu

I have tried with the new update. However the following still occurs (Revit 2021 and 2022):

Using the Railings category as you’ve shown above yields a conversion error within Revit itself:

My grasshopper set up for converting to directshapes are:

I have also tried bringing in the model with a fresh Revit model (so the model extents are as small as possible) however this causes the same issues

1 Like

Hi @RamiEvans,

sorry to hear this is still happening on 2.6.5, not sure what the difference between your setup and @gokermu’s may be to cause this to happen.

Anyway, if you go to your manager settings and activate the “beta versions of connectors” toggle, you’ll be able to see our latest alpha release: 2.7.0-alpha1, which contains the fixes I mentioned on my last message.

Could you give that a go and see if the latest release does in fact fix the issue? We’re planning on making a stable release by the end of the week / beguinning of the following week; so having confirmation this works for you would be great :slight_smile:

Let us know how it goes!

1 Like

Good day @AlanRynne

Using the Alpha update you mentioned the fractured geometry issue is completely solved!

Thank you very much for your time and assistance!


Awesome! I’m glad that one did do the trick.

Just a fair warning. Do not use the alpha for any “project-critical” stuff, as we may modify some things before the stable release.

Obviously, we’ll try to not break anything, but it’s better if you don’t rely much on it until we make the final release :slight_smile: