Grasshopper Speckle Connector install issues

Hi all,

My colleagues are having a lot of issues with the installation of the grasshopper connector.
I’m actually not experiencing it myself, but a lot of my colleagues don’t get the grasshopper assembly copied in their gh library when installing the connector.

When I send them my .gha manually one of two other errors pop up:

1: Could not load type: ‘Speckle.Core.Logging.Tracker’ from assembly ‘SpeckleCore2, Version=, Culture=neutral. PublicKeyToken=null’.

2: Default Speckle Kit not found

Any help would be greatly appreciated.

Hey @MdeLeur!

Thanks for reaching out, we got a report from another user this morning so we’ve already pushed version 2.5.2 of grasshopper to fix this. You should see it appear any moment in your Manager!


1 Like

Thanks for the quick response! Growing headache avoided :laughing:

Hmmm interesting… The update fixed the problems for my colleagues, but when I updated, I got this error:

EDIT: And when I open an existing definition, I can add speckle components, but the default kit isn’t found

Oh, It may have been an issue with the broken install. I did test the update on my side with no issues.

Could you try to uninstall/reinstall the connectors on your machine?

If that doesn’t fix the issue, try deleting your Objects kit folder too after uninstalling.

You can find it here → %appdata%/Speckle/Kits/Objects

Let me know if that does the trick

Actually tried that, and just now did it again, error still occurs I’m afraid…

1 Like

Hmm… I’d love to finally pinpoint this error…

A couple more questions :slight_smile:

  • Could you send us a screenshot of the files inside your Kit folder?
  • Do you also have the Rhino connector installed?
  • If so, does the GH error go away when you uninstall Rhino?
  • Could you check there is no dll file in the installed components folder with the same name of the .gha file? If there is, does the error go away if you remove it?

Sorry for the inconvenience!

Haha me too :wink:

As I mentioned, I’ve uninstalled speckle and deleted all things speckle I could find on my computer, even uninstalled the manager as well.
Now in my Kits folder, there’s only the object folder with this inside:

I tried starting up without the rhino connector both installed and uninstalled, same error occurs. (Deleted the Rhino objects kit as well)

There was indeed a SpeckleConnectorGrasshopper.dll next to the SpeckleConnectorGrasshopper.gha, deleting it did not resolve the issue either.

Thanks for the help

EDIT: Just tried a complete re-install of Rhino, didn’t solve the issue either

The “No default kit found on this machine” error can sometimes be solved with a work around by starting Rhino and run Speckle in Rhino. Then start GH. Not sure if it works in this case since you have other errors.
It’s not a proper solution of course, but it might help.

Thanks @JdB for jumping in!

This error is super puzzling, as when I’ve encountered this the fix has always been the other way around (removing rhino speckle solved the issue, then reinstalling it would work)

I’m honestly out of ideas but I’m wondering, @MdeLeur, if this error is reproducible from a different user account in the same computer (not sure you’re even allowed to create new users if you’re on a corporate machine)

Different suggestion (not sure why this would affect the install differently but here it goes):

Could you try to download the GH connector from and install it manually?

1 Like

Afraid not…

I’m afraid this didn’t work either.

I have to say I’m really puzzled by this too… Especially since the last update did fix all the issues my colleagues had (when I didn’t have any issues).

This actually worked!


Makes me think even more this is a conflict between old Rhino and GH releases…
Do you by any chance have any other installed plugin that might use some of our DLLs?

1 Like

None that I know of… And just the GH connector without the Rhino connector doesn’t work either.
I’m puzzled :thinking:
EDIT: I’ve actually tried to delete everything speckle I could find on my laptop and reinstall only the GH connector

1 Like

Would you be able to do a live debug session with @AlanRynne and myself? We really want to get to the bottom of this one!

1 Like

Sure, would be great! I’ll DM you

It turns out there was a conflict with an old version of SpeckleCore.dll (and other dlls too) loaded by an internal plugin!

Removing it resolved the issue. For others having similar problems you can try the following:

  • create a c# node
  • add this at the top using System.Linq;
  • add this to the function body
A = AppDomain.CurrentDomain.GetAssemblies().Select(o => o.FullName).Where(o => o.Contains("Speckle")).ToList();

And then show us what the output is! :slight_smile:

1 Like