Grasshopper Send and Receive components not working


I got an update for the SpeckleManager today, so I updated that.
But now the Send component doesnt seem to work. I tried uninstalling and reinstalling it.
Current version 2.1.26. I dont believe there was an update for the GH connector.

After placing the Send or Receive component, I cannot delete them.

Edit: Sending a point directly from Rhino works, so Im guessing it’s a Grasshopper issue?

Hi @CCal! Thanks for getting in touch!

I think the only thing that’s going on here is the typical Grasshopper wire missconnection :sweat_smile: Adding to the confusion the error message that is quite unhelpful.

Your sender should look something like this :point_down:t3:First input is the data you want to send (geometry, text, speckle objects… whatever), second input is where you want to send it to (the stream url or branch url)

Screenshot 2021-08-20 at 16.57.00

Sorry for that super unclear error message! I’m opening an issue to provide a better explanation of what was wrong in future versions.

P.S. Feel free to Introduce yourself 🙆 to the community if you feel like it :smiley:

1 Like

Hi @AlanRynne ,

Thanks for the swift response. I did make a mistake in that example.
So I tried again with the two inputs swapped, but i still get an error.

1 Like

Oh no… then clearly something else is failing. Could you check the contents of this folder in your computer?


It should look like so:

Yup, I have the same files. The file size and Date modified both match as well.

Hmmm… so not that. Have you checked that they are not blocked by Windows? If they are it should say by opening their Properties panel.

Also, could you send me your SUUID to check our logs for any extra information?
You can find it in the Speckle Manager → Settings (last item). You can send it via private message if you prefer :+1:t3:

I notice from the video that the Sender component has an error as you place it on the canvas, correct? Can you show its message?
Also, to confirm, are you using XYZ?

Yes, the Send component immediately show red as I place it.

Edit: Yes, Im on the server

Thanks for confirming!
This is quite weird, can you please also confirm that the user under which the GH connector is installed is the same as the user where you have the kits folder?

(you can open the connector folder from GH > File > Special Folders > Components Folder)

Hi @teocomi ,

Yup, the user is the same.

Thanks @CCal !

Let’s try one last thing, then we can proceed to schedule a quick call so we can troubleshoot a bit more:

    var Kit = Speckle.Core.Kits.KitManager.GetDefaultKit();

    A = Kit;
    B = Kit.Converters;


Also, just to check, have you by any chance built and run the GH connector locally on your machine? Is so, it might have polluted you local set up…

Hi @teocomi ,

What do you mean by building the GH connector locally?
If you mean cloning the github repo and building the gha myself, then no, I have not done that on this machine.

Yes, that’s what I meant…

I think you might have forgotten to add these two assemblies in the script:

After adding the references, I get the following:

Hi @teocomi, @AlanRynne ,

Thinking the Speckle installation might be corrupted, I decided to uninstall all connectors and also the Speckle Manager.
Afterwards, I reinstalled everything and now the Send component works again…

Not sure what the cause was, but reinstallation did the trick.


Wow! I’m glad a full reinstall managed to do the trick!

Still a bit bothered about this problem. Thanks for reporting it! We’ll keep an eye on it to try and find the source of it.

Do let us know if you ever experience it again!