Grasshopper receive from QGIS: no geometry received but only speckle objects


I’m new to Speckle and just tried to use Grasshopper to receive my QGIS file from the server. The QGIS layer sent has only line objects (one layer only):

and it can be seen from the speckle server properly as shown here:

However, when I try to receive this in Grasshopper, the output of the receive component becomes “layer” instead of “data”. And it contains “speckle object” instead of “data” which should contain the normal rhino geometry I supposed:
When I deconstruct the object the different keys and info are there.
Can I check if there is anything I’m missing out or how should I solve this?

Also, I am experiencing very often rhino crashes when I use the components, is this normal?

Hey @Yuqin ,

Welcome to these parts!

I guess the geometry is not displayed automatically because it comes nested inside various “speckle objects” (Alan, please confirm if I’m right :slight_smile: ) you can access it with the Deconstruct Object as you mention:

Can you explain what do you mean by this?

Can I check if there is anything I’m missing out or how should I solve this?

And in regards to Rhino crashing, not it’s not normal! Can you tell us a bit more, maybe how to replicate the crashes?


Hi Matteo,

Thank you!
After deconstruct object it works, didn’t realize that previously!

Regarding the rhino crash, it is just after I use the simple “receive” component and pressed the receive button, then for quite many times my rhino immediately crashes (it’s the only component), but the rest of times it is ok. However when I tried a few times just now to recreate the issue it has been working fine now. I will update you guys if it reappears! :sweat_smile:

Thank you,