Grasshopper Adaptive Component issue

Hi Speckle Team,

I seem to suddenly have an issue regarding an Adaptive component sent from Grasshopper. My colleague said it worked fine before yesterday, but now it provides a warning: “Could not find adaptive component [family type]” when Recieving the stream in Revit.

I checked a few things:

  • I have the exact family and type name as input to the adaptive component, I made sure by sending the Family and Types from Revit to GH.
  • Point orientation in the Adaptive family matches the GH point orientation (CCW).
  • I duplicated the adaptive family to see if that would fix something, but to no avail.

Speckle Stream: Speckle

capture at 13;49;27

GM_4Pt_Structural Slab_2Test.rfa (376 KB)

1 Like

Hi @Wes!

Thanks for reaching out, this is quite weird indeed, specially if this exact workflow worked for you yesterday!

Are you aware of any updates that may have happened in your machine? Did you update your connectors by any chance? or is your install exactly as it was when it worked? :thinking:

Hey @Wes just tried and can replicate, this is a small bug we introduced in the last release. Sorry for that, we’ll patch it asap!


Hey @Wes,

Version 2.2.9-beta should be appearing in your Manager any minute now! This should fix your adaptive component problem :wink:

1 Like

Thanks for the quick replies and the quick fix! Works like a charm.