GraphQL Error on server initial setup

Hi there!

So, I’ve been playing around with the current version of the 2.0 server, trying to get it up and running.

I managed to build and run the master branch correctly but it seems I hit a bump in the road!

I followed the instructions in the main (postgres db, redis… etc). But when trying to setup the server at http://localhost:3000/setup I always get the following error:

I’m not sure if this is a misconfiguration on my behalf. I also tried registering directly and that did work, allowing me access to the /explorer route with the GraphQL Explorer.

It appears the user is granted the server:admin role. Once logged in, if I try to access the /setup route, I automatically get sent to step 2, but I am unable to finalise the process due to “not having the required privileges” (there is also a typo in the error message :sweat_smile:)

Any idea what is happening here? Have you encountered this before?

1 Like

Thanks for checking this out Alan!
While we investigate further, could you also try running all the tests in the server?
That might help pinpoint what’s going on…

I just ran the test:server script and all tests pass successfully.

I tried running the dev:server:test script and I get the following info message about not having completed the setup:

1 Like

Hi @AlanRynne! Kindly ignore the setup app - especially in development mode. It’s not ready, and it’s not fully scoped yet. It was just a tryout :slight_smile: (that’s causing complications!!!)

And yes, the first user who registers on the server becomes an admin, just like in 1.0 - we might get rid of that behaviour later.