Failure with Speckle Revit Connector


I’m trying to use Speckle with Revit. I have installed Speckle manager v2.2.6 and installed the Revit connector but when I run revit I get an error:

I have tried to uninstall and install different versions of the connector but I always get the same error.

I would appreciate if you could help me. Thank you!

Hi @Sebas_Alonso ,

Sorry to hear that, can you please confirm in what version of Revit is this happening?

Thanks for your answer. I try with Revit 2019, Revit 2020 and Revit 2021…in all versions the same error message.

This is quite unusual! Do you have other plugins installed? Would it be possible to disable them temporarily?

You can do so by closing Revit and then moving them outside the: %appdata%/Autodesk/Revit/Addins/YEAR folder (assuming they are installed there)

I try to move all the plugins and still don’t work…

That’s unfortunate, since we cannot replicate, would you have 10 minutes to show us the issue?
I have some time today at 3pm UK.

I have managed to install version 2.4.0 and it works correctly. But even uninstalling the Revit plugins I have not been able to get any later version to work.

Thanks for trying that, it is actually very helpful, I think I’ve found the culprit to be indeed a conflict with another addin. There are other locations in which Revit addins could be installed:

User Addins:

Machine Addins (for all users of the machine):

Addins packaged for the Autodesk Exchange store:

Autodesk servers and services:
C:\Program Files\Autodesk\Revit 2016\AddIns\

Here are my findings cc @connor :smiley:
Version 2.4 of the connector and earlier used v1.3 of the Revit.Async library:

But the newer versions have updated to v2.0.1, and Sebas probably has a plugin installed still using the old version of that library.

We can look at directly adding the RevitAsync code in our connector, but in the meantime, the fastest solution would be disabling that other addin.

1 Like