Etabs Connector - Plugin Failed

I’m trying to launch the Etabs connector in Etabs 20. The connector seems to be installed and loaded correctly. See image below.

However, when I try to launch the connector, I get the following error. Would anyone know what’s happening or what I’m doing wrong? Could it be Etabs 20 instead of 18/19? Thanks for your help. Cheers.


1 Like

Hi ,

It seems like everything is loaded correctly as well. Can you do a clean install with an uninstall.

if it still isn’t working, i’m happy to hop on a quick call with you to debug !


Hi Reynold,

Thanks for your prompt response. Yeah, I’ve tried that already and I’m still getting the same error:

  1. Uninstalling the ETABS connector
  2. Re-installing the connector

Unless, I should re-install the whole Etabs which would take a bit longer.

Hi @cokolinar!

I’m not sure how, but it seems like your ETABS Speckle configuration is looking for the plugin in the wrong folder.

The Speckle connector should be under ...\AppData\Local\Computers and Structures\ETABS\...

instead, it’s looking for it on ...\AppData\Local\Computers and Structures\ETABS 20\...

While we double check this on our side, could you ensure that the Speckle2ETABS folder is where it should be. And if so, try changing the PluginPath to check if it works?

Obviously this is less than ideal setup process :sweat_smile: Sorry for the inconvenience!

Hi @AlanRynne,

I’ve changed the folder to the default folder …\AppData\Local\Computers and Structures\ETABS.… and the plugin seems to be loaded correctly. Unfortunately, I’m still getting the same error that the plugin failed when clicking on it.

I spoke to @Reynold_Chan about it too and I’ll try to downgrade my Etabs from 20.3.0 to 20.1.0 first.

1 Like

@AlanRynne @Reynold_Chan ,

I managed to load the plugin in Etabs 20.1.0 and import the model from Revit. Some elements (walls, supports, and even some columns) were kind of missing in my Etabs model but I’m assuming it’s because the connector is still in alpha stage?

The Speckle commit was showing a full model send from Revit.

Must be something going on with the 20.3.0 version.

1 Like

That’s good ! it means that probably something happened in 20.3.0 version on their side. I’ll give CSI support a ping and hopefully get to the bottom of this.

Are you exporting elements through the analytical model ? i’m assuming you are. Can you share the speckle stream with us so we can work on the missing elements that you’re expecting to recieve fully.

Thank you.

Yes, I’m exporting the elements through the analytical model. It’s funny because most of the elements are there.

The commit: Speckle

Missing Etabs elements circled in red.

1 Like

ah yes 2D elements are missing on recieve right now.

I will add them in the next release or the release after that.

Cheers and thanks for testing !

Is there anything else you would like to see to be updated ?

It would be really good if the following information would flow through to Etabs. It would speed up the workflow significantly:

  • 2D elements (like you’ve mentioned) such as walls, slabs
  • Correct member properties (I’ve seen the disclaimer about units on the tutorials page). This could maybe be done to some degree through additional interface when importing the model to cross check the correct member sizes in Etabs. Similar to CSIxRevit plugin.
  • bonus: supports/restraints from the analytical model
  • Import from Revit 2023 (analytical model has different tags in 2023).

I’ll be exploring the following workflow next:
Revit → Grasshopper → Etabs → Updated Revit

I’ve also noticed I can’t send my Etabs file to the stream (frame and area elements only), it keeps sending the model forever and nothing is sent. I’ve created the Etabs file from a Grasshopper script. The Etabs file is saved here.
Is it because some frames are not named as per typical convention, i.e. 250UB31?

Appreciate your support!

1 Like