Errors when getting started with DigitalOcean Docker Droplet

Following this documentation: GitHub - speckleworks/SpeckleServer: Speckle Server 🚀
I have deployed a DigitalOcean Docker Droplet and I have no problem getting access to that speckle server in the browser, registering a user, and logging in.

When in the Rhino Pane, I am receiving errors with either registering or adding a user.
I’ve tried the following API URLs with the IP address that works in my browser:

Here are things I think could be the issue but am unsure how to resolve:

  1. There is existing documentation I should be reading before posting here
  2. I’m using the wrong server api url
  3. There could be a firewall issue on PC or Server side

Any help would be much appreciated

Hi Nico,

The last address is pretty much the one you want. I don’t know if this will make a difference, but have you tried writing it as “http://ip:3000/api/v1”?

The fact that you can use the web interface suggests that it is not a firewall issue in the server side, at least.

If you have access to another computer with Rhino, it could be worth trying from that.

Let me know how it goes. If those don’t work, @dimitrie might have more Rhino-specific ideas :rhinoceros:

Can you post some screenshots of those errors here? Am unsure what’s going on. Regarding docs, this discussion here now will help shape them up!

off the top of my head, do add https://ip:3000/api/v1 or if no ssl cert, http://ip:3000/api/v1 (no s at the end of http).

Thank you both, It was as simple as including http:

The error codes were generic but did point to the issue. I’ve listed them below in case they provide a clue for someone in the future:

DOMException: Failed to execute ‘open’ on ‘XMLHttpRequest’: Invalid URL

Uncaught (in promise) TypeError: Cannot read property ‘data’ of undefined

1 Like