Errors in GetObjectListProp when extending Objects kit used for grasshopper

Hello, community,

I am creating a custom object in the Object Kit that we want to use in grasshopper.

For testing, I firstly receive the stream from speckle and then deconstruct the speckle object, to feed in the correct attributes to the created scheme object component. Then I get an error when assigning one attribute as is shown below. The error message is ‘Value cannot be null. Parameter name: elementType.’

I did some debugging and then found that this happens in the GetObjectListProp function in CreateSchemaObject.cs. In this case, the demands of Typology should be a list of Parameters (Objects\Objects\BuiltElements\Revit\Parameter.cs), then it tries to create all the objects in the list. But in this case, the listElementType will result in null, because t doesn’t have ElementType.


To see if this is an error from my custom class, I tested with roofs (Objects\Objects\BuiltElements\Roof.cs) in the grasshopper use both the native component and the schema object component. I got the same error.

I’m actually not sure how to solve this issue because I’m not familiar with Object kit nor c# actually😅 Hope you guys can give some help or guidance, thanks!

Hi there @He_Patrick!

We fixed this issue recently, and should be released in our next stable release 2.8, but if you want to give it a try, you can install the latest alpha version 2.8.0-alpha2 from your Manager. :slight_smile:


Hey Alan, thanks for the reply!

I tried today with 2.8.0-ALPHA2 and tested again with Revit roofs, I got the error again.
I also tried with the release/2.8 branch actually but they gave the same error. Do you maybe know how to check why this is still giving errors?


Hi @He_Patrick!

thanks for getting back to us with this :slight_smile: and I’m sorry it’s still not working for you.

As far as I can tell, this is not the same error you were originally getting right? Or am I missing something?

I’ll have a peek at this tomorrow first thing.

Hey @AlanRynne we figured it out this is caused by one of the parameters which is actually a string but not a Speckle Parameter, so this is not a problem anymore, thanks!


Awesome! Don’t hesitate to get back to us if you bump into any troubles!! :rocket:

1 Like