Error Step 2: Build and Run Your Code

I am trying to deploy a Server following the steps in Deploying a Server - Manual Setup | Speckle Docs

When i run the command docker compose -f docker-compose-speckle.yml up --build -d in the last step i get this error with Yarn
Step 24/41 : RUN yarn workspaces focus -A
—> Running in 1bdf4aec3a13
➤ YN0000: ┌ Resolution step
➤ YN0013: │ @types/react@file:./packages/frontend-2/type-augmentations/stubs/types__react#./packages/frontend-2/type-augmentations/stubs/types__react::hash=2ea486&locator=root%40workspace%3A. can’t be found in the cache and will be fetched from the disk
➤ YN0002: │ @graphql-codegen/cli@npm:2.13.7 [ede1a] doesn’t provide @types/node (p32873), requested by cosmiconfig-typescript-loader
➤ YN0002: │ @graphql-codegen/cli@npm:2.13.7 [ede1a] doesn’t provide ts-node (pfab76), requested by cosmiconfig-typescript-loader
➤ YN0002: │ @graphql-codegen/cli@npm:2.13.7 [ede1a] doesn’t provide typescript (p5f479), requested by cosmiconfig-typescript-loader

Thanks for trying to build Speckle server and sorry you’ve bumped into some issues.

Firstly, which operating system are you using?

In the output you have provided I’m unable to identify any error messages - they appear to be warning messages which shouldn’t stop the build. Can you please provide more of the output, or a screenshot?


Hi iainsproat! Thank you for your response!

We are using Debian GNU/Linux 12.

The problem is that we dont have an error message, the build freezes always in the same point and we have to abort the execution.

I attach here the complete output, if you need to see other information please let me know!
SpeckleError.txt (23.0 KB)


Hey @mabover

I tried to reproduce your issue, but i was not able to get things stuck on Deb 12.

Can you check, that your ( i presume VM ) machine has enough CPU, RAM and disk available? Its especially weird, that the build fails for you during the docker build stage. In our CI, we’re using a build image derived from latest debian and we have not had this issue before.

1 Like

The VM specifications are as follows:
Disk memory: 40GB (25GB available)
CPU: Architecture: x86_64, Intel(R) Xeon(R)
Does it accomplish the minimum requirements to deploy the server? Otherwise what do you recommend?

Thank you for your response!!

@mabover - if you are only deploying the server and do not have a requirement to create new images (i.e. you have not customised code which needs to be built) then I would recommend deploying without building.

Please refer to the docker compose files suggested in our guide for examples on how to deploy without building the image. This would allow you to omit the --build flag in your docker compose command.


1 Like

Hi Iainsproat!
The problem it´s that we need to create the image.

This problem can be related to the proxy? Because we don´t know where set it…
Can you tell me where i have to set my proxy in the docker-compose-speckle.yml?

Thank you!

If you need to see our documents (docker-compose-speckle.yml and others) let me know and i can attach it here!

@mabover - you mentioned a proxy. Is this something you have in your network infrastructure? Does it control your access to the internet?

If so, Docker has some documentation related to proxies here: Configure Docker to use a proxy server | Docker Docs
And you may find this guidance related to docker compose helpful: How to use local proxy settings in docker-compose - Stack Overflow