Error Loading Speckle Rhino Plugin

Did anyone run into this?


It looks like the Rhino plugin is not installed properly, or something is not right with my version of Rhino. Are there any special requirements?

Going through the Options>Plug-ins>Install gives me this:

…which is unfortunately too small/not able to expand the window to even see which DLL failed to load. Is there a log file somewhere in Rhino that I can retrieve this information?


cc: @dimitrie @luis

Ok, solved. It looks like I downloaded the x64 version of the plug-in but was attempting to load it into a 32bit Rhino. Of course. I doubt anyone uses that version of Rhino, neither do I. It was a mistake.


1 Like

It’s actually more widely used than you think, but i suspect it’s mostly people just using the first shortcut they encounter! There were quite a few problems with this before…

Hi guys, i have a similar problem with rhino 6 that tell me :

System.Exception: No PlugIn subclass found.
** in Rhino.PlugIns.PlugIn.CreateFromAssembly(Assembly pluginAssembly, Boolean displayDebugInfo, Boolean useRhinoDotNet)**
Unable to load SpeckleWinR6.rhp plug-in: initialization failed.


could you send me a screenshot of your rhino loading splash screen? The important part is the version number; we might have upgraded to a newer sdk release and, consequently, caused this problem - but not entirely sure. We’re using 6.1.18.

i have latest sr
rhinoceros 6.13

Not sure then what the problem can be; maybe the installed plugins are still blocked by windows? You can check the install location like this:

and try and see if they’re blocked.

Unfortunately my other non-development machine is out for repairs right now so I can’t test this myself - but maybe someone here has more ideas…

I do have noticed i have rhino 6.12 installed, will upgrade later on let you know how that goes - maybe it’s a 6.13 thing.

i don’t see speckle in the list…

But i have

speckle in the plugin folder

is by any chance the .rhp blocked, or any of the more obvious dlls in there? would ideally like to see the stack trace of this - does rhino provide more info besides the rather cryptic warning you showed us earlier?

no more file blocked…and no more information beside the warning message…you can see attacched file

you can see also this :

Hello Francesco, will attempt to have a look later on today and try and post an update; it’s a bit of a curious problem :grimacing:

Okay, some extra questions for you @francesco_perego! With @Alessio_Lombardi we’ve encountered this, and it was solved by the following:

  • take care that there’s no residual SpeckleCore.dlls left around anywhere. This should not be an issue if you’ve used the installer, but you never know - especially if you built it before yourself.
  • Something might have went wrong, and some dependencies are not in the right place. Can you check in %localappdata if you have a SpeckleKits folder, and if there’s anything in it?

This may or may not solve your problem :slight_smile: Let’s see!

1 Like

i have 2 copy of speckle folder (see attached) and nothing specklekits folder

and nothing specklekits folder

Okay, that explains it then - i think. somehow, during the install, you might’ve unselected the misleadingly named SpeckleCoreObject Model:


This means that it didn’t get installed in its traditional place, which, on my machine is at C:\Users\dimitrie.stefanescu\AppData\Local\SpeckleKits. Can you try running the latest installer again? Thereafter, you should see a SpeckleKits folder in your local app data folder, which should contain the required dlls.

Let me know if this helps you out. Otherwise, if there’s no specklekits folder there must a problem with the installer and your specific setup; in which case I’ll have to look deeper.

I’ve logged this issue: No SpeckleKits folder throws unhanded error · Issue #119 · speckleworks/SpeckleCore · GitHub

I can confirm that the above works. Problem was that I was using the RHI installer found at GitHub - speckleworks/SpeckleRhino: Rhino 6 + Grasshopper Speckle Clients via link

Was not aware that the above link was deprecated or referencing an older version/build? Should the docs be modified?

1 Like

Yeah, I’ve changed the readme now to point to the installer.

speckle.exe work good
many thaks Dimitrie!!!

1 Like