Error in Grasshopper while receiving Data "You don't have access to stream "XXXXX" on server, or the stream does not exist."


I am getting the following error while receiving data in the Grasshopper.

  1. You don’t have access to stream bee482c5b6 on server, or the stream does not exist.

Hi @Sameer_Shah, it definitively seems to exist, and you definitively have access to it, so it might be the case of some account confusion from what we’re seeing at our end.

We’ll try to get to the bottom of this, and we might send you a private message, as we might need to discuss some delicate details re your accounts on xyz :sunglasses:

1 Like

For anyone jumping on this thread, it turns out it was an issue with the windows firewall! :fire::brick::boom:


Hi, I have the same problem with 2.6.3, I even checked with turned off firewall.

1 Like

Hi @reka,

Could you check if your Speckle Account in manager shows up with a :white_check_mark: or a :x:? It may happen sometimes that your account token doesn’t get renewed properly, leading to a similar error.
Screenshot 2022-07-06 at 16.04.08

Try and remove and add again the account, to ensure its working properly.

Other than that, maybe @dimitrie or @teocomi have some other things to look into?

To add on top of what Alan said, is this a stream you created or that someone shared with you?

Hi @AlanRynne , @teocomi
Thanks for the quick answer. My speckle account seems allright but I removed and added again without any success. Accounts component in Grasshopper shows it properly too.

I created the stream myself, but I tried to make a brand new stream, I used a brand new Grasshopper file, the result was the same.

I downgraded to 2.6.1, which solved the problem, but some of my Grasshopper files are insanely unstable. Maybe because I have 6 recieve components for different streams? Also some Honeybee components are not working in this file, while it works well, when I have just a send component.

Send us a link to that stream, or add me ( as a collaborator and we can try to dig deeper! Is your account with the same email as you’re registered on the forum?

We have our own speckle server, I’m not sure, how can we add you as a collaborator.

1 Like

Oh, you’re using your own deployment? :partying_face:

Does the error message reflect the correct url of your Speckle Server?
Could you also try in our public server (if you haven’t already)? :slight_smile:

If you send it to XYZ we all have accounts there so you can just search for us by email/name (

It seems, it can be some problem with connecting to our own deployment. It works well with the public server. We have Community Server v2.3.0

1 Like

Thanks for sharing! Yes, that sounds like a deployment problem, also the latest server version is 2.6.3, you should consider updating :wink: