Dynamo: Outdated version of Speckle


I’m having trouble with the Speckle version in Dynamo. I’ve installed via the package manager and the files from Github but the components in Dynamo are still showing that Speckle is outdated. Would anyone be able to help?
Many thanks,


Theoretically they should show you where to download them from! Anyway, we’ve moved away from the package manager - so uninstall those, and then grab the latest installer from here!

Let us know if it works out! This will also keep your versions up-to-date automatically.

1 Like

Hi Dimitrie,

thanks for your quick response. I’ve tried the installer from Github but I can’t see speckle at all in the Dynamo Library. Do I need to move any installed folders manually to the Dynamo package folder?

I managed to get it to work. Speckle hasn’t been installed in the default user location but in admin folder.
All seems to work fine now.
Many thanks and a good Christmas to everyone!.


1 Like

Ah, dang. Growing pains. We’ll have to look out for this in the future…

Hi Dimitrie

other issue…
i can’t see speckle in dynamo…
i have instaòled from here Release Speckle-v1.3.7.137 · speckleworks/SpeckleInstaller · GitHub


what version of dynamo and revit do you have? we currently do have a bug that keeps it away from dynamo sandbox if afaik; not sure if we fixed it…

revit 2018 and dynamo 1.2.2

yeah, there you go - speckle needs dynamo 2+, and there’s no way around that… :confused:

ok!!! i’m updating

Hi Dimitrie

i have updated dynamo and re-installed it with speckle.exe but i don’t see speckle in the package list!

Hi guys
i did other test, speckle doesn’t work with dynamo versions beyond 2+ but only with 2.0.0!