Curve in Rhino/Grasshopper Not Displaying Properly in Viewer and Dynamo as well

My main aim here is to use Speckle to stream Curves from grasshopper to dynamo. however, the Curves that I input into the stream are being displayed in the Hestia Web Viewer but they look very off from what I expected them to be.
Here’s an image of the curves from rhino

While heres an image of the curves in the Hestia Web Viewer

Obviously theres quite a big difference here. I tried receiving the stream back into Grasshopper, and there were no issues at all. So i Thought that it could simply be a viewer issue, and that I would possibly still have the curves proper in Dynamo. However, there is still some discrepencies.
Here’s what it looks like.

Could I be doing something wrong here?
The stream ID is JOi56OCVB

Thanks for the detailed report @yong_siang_ong! Indeed, there is a viewer issue (especially around arcs). Regarding the dynamo conversion, that seems quite annoying. I’ll rope in @teocomi to see if there’s any easy fix; thanks for sharing the streamid as well, makes our lives much easier!

While this is being fixed you can still rebuild and clean your curves before sending them. Usually what I do is (1) to divide them by points in GH, (2) make sure there are no duplicates in the resulted lists, (3) re-interpolate those points before (4) sending them again… Usually this do the trick

I tried what you did, but the result is the same. Unless I interpolated the curve at degree 1, which kind of defeats the point for my particular work case, as I’m looking to get a smooth curve instead of a segmented one.

Thanks @dimitrie hope that the issue can be solved soon. Seems to be quite a critical issue in any case.

Then last resort would be to just send lists of points and interpolate them in dynamo… :see_no_evil:

Haha what a hack, but yeah I agree. that would probably be my last resort. as long as i get the necessary data across.

Hello @yong_siang_ong! I’m having a look at this now, seems the stream has changed, can you please make a new one with the problematic curves?

Hmm thats odd, I dont think it changed. but anyways, heres a new streamID bF-I6jLIV

We’ve found the bug, sorry about that! Some changes we pushed to Revit (more spefcifically SpeckleElements) caused curves to fail when converting to Dynamo…
Will publish a new release later today!

Pre-release here if you’d like to try:

1 Like

Awesome! Thanks alot for the fix!