Create Revit Wires from Grasshopper

Welcome to the Speckle community!

  • I’m trying to use the Revit wire component inside Grasshopper, it has a construction point inputs that does not allow me to give it the grasshopper 3d points

-The question is: does the component need the Revit construction points and is there any way to convert grasshopper points and pass the additional information like level, callouts …etc., or is it a bug in the component that does not work in the real life?

1 Like

the Revit wire component is in the Revit components that you can show from the speckle 2 menu

Hi Gehad,

Welcome to Speckle!

Can you please share a screenshot of your Grasshopper definition?
Make sure to click on the red balloon so we can see the error.

Thank you


this is the screenshot of the error when I tried to give the component the wire line control points from grasshopper, it seems that it cannot take the grasshopper points and it needs the Revit construction points, is there any way to pass the construction points to the component input ?

Can anyone replies to me please!

Hi @Gehad_Hamdy ,

Can you try sending the first input (constructionPoints) as a list of numbers corresponding to the X, Y, Z coordinates of each point instead?

Yes, I grafted the list of points then deconstructed it then merged it and plugged it to the input, and still didn’t work

I sent it as a tree the first index is x, second is y, third is z, for each point in the list as a tree

Try sending your tree as a flat list of {x1, y1, z1, x2, y2, z2, …, xn, yn, zn}

Thank you I think this will work, but If it is flat, then how can I make more than one wire, it will be a component for only one wire ?, or is there a way to pass it the information of multi wires ?

I have a list of crvs how can I use it if the the input is flat ?

Hello all, I am using the Revit Wire component, but it does not work, I passed the inputs as the following, first input (construction points): I passed the points as a flat list as the following (x1,y1,z1,x2,y2,z2,x3,y3,z3), second input (Family): I passed the following string text (system Family: Wire Types), third input (type): Default, fourth input (Level): I passed to level by name component an existing level name then passed it to the input, then the component have no errors but it does not send anything to Revit, otherwise I used the pipe component in the same way and it worked with no problems .

I pushed the Revit pipes before, and it is pushed successfully as it is shown in the filter in Revit, so there is no problem in the send process, the problem is in the component obviously.

sorry guys :pray: :pray: , it worked successfully, we should choose the view to show it

Hi @Gehad_Hamdy,

Is your problem resolved now?

Let us know.

Yes :ok_hand:t6: , thank you for the support, and it will be superb in the future if you can update the components so that wire can watch the connectors to hold the information after they are sent in Revit, and also it will be good if we can create a new family with speckle

1 Like

Ok great! Thanks for the feedback, really appreciate it!

there is also an issue that may cause a problem, or maybe I did not get it right so that I need an explanation, the Revit wire component takes its inputs including (points and levels), but to be sent in a right way the active view should be a floor plan, right? I noticed that when I send data to Revit, it receives all data in the active view which is the selected floor plan ignoring all levels which was given to each wire, for example if I created wires in 3 floors building and assigned 3 levels in Revit (Ground, first and second) then gave each wire in a different level its own level, then tried to send all data after activating one of the three floor plans I made for example Ground, then all wires will be created in the Ground active viewport ignoring all levels assigned to them .
So, if I do not understand, it would be nice if you clarify or tell how I can use component and send in the proper way, noticing that all data are matching in Grasshopper (there are no problems in data tree)