Cloning DesktopUI Repository


I’m trying to clone the DesktopUI respository to have a play around (from speckle-sharp/DesktopUI at master · specklesystems/speckle-sharp · GitHub), but GitHub Desktop continually asks me for my login details and authentification:


I enter my details and it prompts the box again. I have tried cloning other repositories (non-speckle related) and it works just fine.

Any ideas why?

Hey @dtnaughton, I don’t have any clue. We don’t have any funky permissions set up whatsoever. I’ve had similar issues recently myself - but I just needed to move from password auth to a PAT token for the commandline git.

I’ll bet if you download the code it’s going to work just fine (i just tried that in an incognito tab), so there must be something weird going on with your setup; perhaps some invalid old cached credentials?

@dimitrie Hey Dimitrie! Thanks for the quick response. I actually just managed to solve it by cloning the whole speckle-sharp repo as opposed to just going for the DesktopUI.