Civil3D connector STUCK on "Send"


New user here. I am using Civil3D 2023 and Civil3D connector 2.12.2.

When I try and send an alignment, I select the alignment, click “Set Current Selection”, type in my message, then hit “send”.

After that, it just hangs on “Send” with the moving load bar as shown in the image.

I have tried this in 2022 as well. I have tried it with a test alignment. I have tried it after turning off my company VPN.

Any thoughts on what I am doing wrong?

Thank you in advance!



Hey @gio.didomenico ,

Welcome to the community! Feel free to Introduce yourself :person_gesturing_ok: to the community if you want to! :grinning:

Hmm, this looks interesting. It should eventually send it even if it’s slow. Can you share the source file so we can replicate this issue on our end? You can send a PM if you don’t want to share it publicly.

1 Like

I let it run all night and it never sent.

I just tried creating a blank file with the default C3D template (dwt) and put a test alignment in, and it sent instantly.

This led me to look into my drawing settings. I can get it to work if I change the drawing units from US Survey Feet to International Feet. Once I change it back to US Survey Feet, I can no longer send to the stream.

Is this a known issue with US Survey Feet? I must use that unit on my projects, so maybe I can do a transformation of the data before trying to use speckle. but for many linear civil infrastructure projects, US Survey Feet is the required unit of measure and it would be great if Speckle supported its use.

1 Like

Hi @gio.didomenico , I just added a quick fix to support US Survey Feet in our units - thanks for the bug report!

You can track the status of the fix here: feat(core): adds us survey feet support to units by clairekuang · Pull Request #2208 · specklesystems/speckle-sharp · GitHub


Thank you very much!