Can't send Excel data to Speckle when not using the main branch

Hi everybody,

When i am trying to export my excel data to a branch which is not the main branch nothing appears in Speckle, even though i am getting a “Data sent succesfully” message, see snippets below:

Did i do something wrong when setting up my branches/ are they not designed for that or is this just still a bug in the connector?
Any help would be greatly appreciated. :slight_smile:

Kind regards,

Hi @DaanSchlosser!

Thanks for reporting this. Sending data to any branch is definitely supported. I tried reproducing your problem in a different stream, I created a branch with the same name Excel Streams and I was able to send some basic data without an issue. Just a couple of quick questions/requests to try pin-point the problem:

  • What version of Excel are you using?
  • Is it the Desktop or Web app?
  • I guess you were able to send that exact same data to the main branch. Could you confirm it?
  • Could you try sending to a branch with a “simpler” name like: excel streams(no capital letters) and just excel. This would help to localise the problem.

It could potentially be helpful to have also the data (or a part of it) that you are trying to send to try and reproduce the problem. If this is something you’d be willing to do (if its not confidential…etc) you could send it in a private message :wink:

Also, pinging @teocomi as he may have an idea of what could be going on. :thinking:


Hi Alan,

Thanks for the quick response!
As an answer to your questions:

  • I am using Excel build “Microsoft® Excel® voor Microsoft 365 MSO (16.0.14026.20270) 64-bits”
  • I used the Excel Connector add-on to send/ receive data, i don’t think i used the desktop app/ web app for that.
  • Yes, when i tried to send data into the main branch everything worked perfectly :slight_smile:
  • I also created 2 new branches with your suggested names, both worked perfectly! However when i tried to send data to my original “Excel Streams” stream i got this message. I think it has something to do with the capital letters.

I also added my Excel file through this link:

Kind Regards,


Awesome! Thanks for the quick reply too! I’ll talk with the team today to figure out what’s going on, but this will definitely help!

We’ll keep you posted here with any updates :+1:t3:And again, thanks for taking the time to report this :grin: