Cannot install connectors

Hello SPeckle team;
I installed a local copy of speckle server and then i installed the desktop UI, then I tried to install some connectors but it failed; this is the screen shot when accessing the speckle server

and am stuck at this step when trying to install one of the connectors

I appriciate if someone can help

Hey @Musab_Omariyeh ! Thanks for the report, I think you’re facing the same issue as @SamerB .

I have made some changes to Manager that will help us narrow down the issue a bit more, can you please install the beta version of Manager at the link below and let me know if you can install connectors?

If not, what error message do you see now?

Another thing that you could try is to ask your IT department to add our Certificate to the list of trusted ones:

If also that doesn’t work, I can provide you with direct links to install the connectors, although that’s not recommended as then you would not get any updates.

Fingers crossed! :crossed_fingers:

Any idea how to get this on the computer?

Message says “close any app using speckle and try again” I’ve restarted and opened with nothing else, have uninstalled and reinstalled the manager.

Hi @veryshinything , corporate setup can be quite aggressive!
Can you please try what described in my post above here and let me know?

Thanks, @teocomi; I am getting the same error after I installed the latest beta version you advised; however for the certificate; from where I can download your certificate to install it to my computer

@Musab_Omariyeh thanks, can you please send a screenshot of the error message? It should show a different text in the beta version.

The certificate is on the SpeckleManager.exe file, simply right click on it > Properties > Digital Signatures > Details > View Certificate. Someone from IT should be able to assist you with that!
We’re also happy to schedule a call with your IT department to better understand how we could satisfy their requirements…



The manager updated this morning to a new version. This worked no problem, looks like I’m ready to test today!


Awesome, thanks for reporting back!

Hi teocomi
I still got an issue when trying to install grasshopper connect; with no descriptive error message;

is there a log file where the system logs the issue so we can check there

Hi @Musab_Omariyeh , thanks for the screenshot.

It seems that your proxy settings / VPN are completely cutting Manager from the web (none of the information displayed is up to date and none of the content is visible, the last version should be 2.1.26).

It would be best to schedule another chat with your IT department and see how we can resolve this.
If they haven’t tried it yet, unblocking these URLs could be a solution.

Hi, I got this installed but the Revit connector couldn’t see my project. Went to update and back to the “Failed to Install” issue. Is it possible to get a stand alone for Revit to test the one thing I was checking?

Here’s a direct link to the latest Revit “standalone installer”. Please note that if installed this way it will not “auto update” - and we release bug fixes and new features bi-weekly.

I’d be happy to schedule a quick call and try to troubleshoot your issue, just let me know!