Can not access geometry data

Arg… @gokermu, I need your help again.

I’m still having trouble properly navigating the dictionary to get access to any of the geometry data.



Stream: Speckle

Hey @MartinSpence ,

I have sent a request for access.

PS. Can you also explain what are you trying to achieve by extracting those values?

Ah sorry, forgot that specific steam wasn’t public.

Well, end goal is to produce a surface I can use to perform QA of distances between said surface and a structural slab, which will be above the surface. The surface will represent the flooring in a parking basement, and the distances will represent “free height”

To construct the surface in Dynamo I need the point location data, which im retrieving from a CAD-file.
The line from where I want the “end”-data is a part of a block that indicates an elevation point, but as this block consists of both geometry and text, I though the most precise would be to try to isolate the line geometry, and the use the mid point of that line.

Neither of the landscaping architect and the civil engineer work in Revit, so I’m translating data from AutoCAD and Microstation, in order to perform the QA.

Hope it makes some sort of sense :slight_smile:

Ok, I understand your issue. The attribute you are attempting to access is defining the geometry of an element. Specifically, you are trying to access the start and end points of a line element that is part of a block.

If you want to access the geometry, I suggest using the “transformedGeometry” key that we autogenerate. It contains the block geometry in the correct location, so you don’t need to make any transform matrix to align those elements properly.

You can still get the start and end points of the lines using Dynamo nodes as they are converted into Dynamo geometry. From here, its a matter of subtracting values to get mid points. Hope this helps!



That is awesome.

But hey, I don’t see the “transformedGeometry” anywhere.

Can you show me how to browse that in the dictionary?

Hey @MartinSpence ,

That attribute doesn’t exist in Speckleverse. It is automatically generated when we received blocks in Dynamo. It generates transform, transformedGeometry and insertionPlane attributes for easier access.


Ah alright.

In my first post on this, I showed that I don’t get any previews in Dynamo, as this image:

So I’m sort of doing this blind folded and completely relying on what I can browse in the speckleverse :-S

Perhaps i should try the uninstall the Dynamo connector and reinstall?

And it’s not because I don’t get any data through :slight_smile: :

Interesting, what version of Dynamo and Revit are you using?

Revit 2023.1.3

Hello ,@MartinSpence…!

Not only extracting the elements but also extract the transformedgeometry

1 Like

Cheers for chippin in, @Pavan01.

I’ll be sure to check it out :slight_smile:

1 Like

Hi again,

Just wanted to do a follow up on this, in case it might help others in a similar situation.

I managed to successfully generate the surface from the points coming from AutoCAD via Speckle to Revit via Dynamo:

Here some close-ups on the Dynamo part, so you can see the nodes:
Receive geometry from Speckle:

The geometry from speckle came without Z-values. The Z-values where stored as a text attribute, so i had to do some string to number stuff, in ourder to create the actual point geometry:

Then some transformation of the coordinatesystem to align the geometry, and then finally create the topo:

I set the IFC properties, and then exported the surface to IFC:

All of the above now lets me perform what was the end goal: Quality assure clearence heights in the federated model between the surface and MEP-components, for which I’m using Solibri:

Cheers for all the help I got here :slight_smile:




1 Like

Thanks for sharing your workflow @MartinSpence ! Glad to hear it did the job for you.


Cheers @gokermu :-).

Btw, I still have the issue with the preview of the Speckle Receiver node i Dynamo.

I tried to reinstall 2.17, and I tried installing older versions as well, but no luck unfortunately.

I’ve checked in Revit 2022, and here the node worked as expected.

1 Like

Hey @MartinSpence ,

We need to look into that. I am guessing we never supported that in Dynamo versions using the new theme.

1 Like