Blender import error on installation

I have some updates.

It’s looking like BlenderBIM recently added a dependency of urllib3 2.x which is incompatible with the urllib3 1.X version that our Blender Connector requires.

I’ve tested version 230506 of the BlenderBIM addon, before they added urllib3, and there’s no conflict here; both plugins load correctly.

Our current advice then, is to use this slightly older version of BlenderBIM if you also want to use our connector.

We’re currently investigating what we can do to resolve this. However, it may be beyond our control as we wait for GQL 3.5.X who’s waiting on graphql-js 17.X to release a stable build :pensive:

Please let me know how acceptable using version 230506 of Blender BIM is for you all.

1 Like

For anyone else experience similar errors without BlenderBIM. Then likely you have a different plugin that also conflicts. In these cases.

  1. Please, try disabling your other plugins to find which one is conflicting.
  2. Open a new Topic here on our forums, letting us know the name and version of the plugin that conflicts. What OS you are using, as well as the error message that is displayed.
    Also let us know if you have tried other versions (newer or older)
  3. If all else fails, and you just want the Speckle addon to work, then follow these steps to uninstall conflicting plugins.
1 Like

In general - of course it is OK from my side.

Thanks a lot for pointing me to it !

I was pretty sure that I use the latest official BlenderBIM, no betas.
And 231104 is the latest official.
So I checked my BBIM AddOns for 4.0 and 4.1 and had to realize that
these had only a BBIM from September !?
Must have happened with Blender 4 switching and setting migration.
I expect Blender 4.0 official took the AddOns from the old abandoned
4.0 Blender Beta Settings and latest 4.1 Alpha migrated them again …

231104 is the version I expected to have.

Now I updated BBIM on both Blenders to 231104 … and now
Speckle AddOn and BlenderBIM coexist peacefulle beside each other
and work flawlessly.

I am pretty sure that this may be the same reason for my problem
with Blender Speckle activation on Windows …

My apologies, I must have copied the wrong version number :man_facepalming:
I meant to say version 230506

it did not work here with a 2309xx.
But it now works with 231104 !?

Probably because I deactivated BlenderBIM, rebooted, uninstalled BBIM,
checked Speckle (AFAIR they were all already activated) and then
reinstalled current BlenderBIM.

I checked both Blenders, 4.0.1 and 4.1.x Alpha.
Speckle AddOn is available and downloads my Stream.
(But I changed from XYZ to Speckle latest Server this time)

OK, I have to admit it does not work.

I have updated Blender 4.1 Alpha to latest now and suddenly both Speckle
and BlenderBIM got deactivated and would not activate again with
usual error messages.

So I searched and found a new official BlenderBIM version and tried
the usual uninstall/upgrade procedure which did also fail.

Unfortunately this happens in Blender 4.1 Alpha as well as 4.0 official (!?)

At least the trick with installing Speckle from Manager - while no BlenderBIM
installed seems to still work.

So Speckle for Blender runs fine on both, Alpha and official.

it looks like I am no more able to install BlenderBIM in my Blenders at all
(Maybe as long as Speckle installed, active or not, but I would need to test that)

230506 is the newest version of SpeckleBIM that we currently are compatible with.

1 Like


Blender 8.1 and 8.2 works for me here fine with
latest(!) BlenderBIM and Speckle.

The problem why I was no more able to install BlenderBIM
in Blender Versions above 8.0 - was just that Blender 8.1+
uses a higher Python Version.

And I missed BlenderBIM py311 downloads as they sorted in the
list behind py310 version !
(BlenderBIM P311 versions had been available since months)
So since I realized that, installation and activation of BlenderBIM
in current Blender official and alpha works like a charm.
(FYI, latest py311 BlenderBIM versions do not install on previous
Blender 8.0 this needs a previous Python version)

So for me also BlenderBIM AddOn does not interfere with Speckle AddOn !
I updated to 2.18.1

There is only one issue.
My (existing) Blender 8.2 Alpha Settings Folder was ignored by latest Speckle Update !
(It was 2.18.0)

This is not for the first time that not all Blender Setting Folders got updated.
I am just not sure if is really especially 8.2, or alternating between any of my 8.x
that Speckle Manager misses to update Speckle AddOn in some of Blender Settings.

I did it the Speckle Update from 2.18.0 to 2.18.1 manually by replacing the SpecklyPy
Folder in Blender 8.2 Settings by the one from my 8.1.