AutoCAD Commit Creating Lines from Origin Point in Speckle

As I pushed CAD elements from AutoCAD to speckle, surfaces tying the elements to the origin point appeared. Is this a setting that can be turned off?

1 Like

:wave: Hi @bcall!

Not sure what could be happening here, and our in-house expert in the ACAD connector, @clrkng, may not be available to check it out until next week.

Meanwhile, would it be possible to share the stream where this happens with us?

It would also help to have the original file (if possible) so we could test things on our end. You can send it privately if sharing it publicly here is not an option :+1:t3:

Does this happen in the viewer only? Or also when you receive the geometry in other connector?

Hi Alan,

It looks like this is only happening in the web viewer. When I pull the elements into Revit, it is no longer an issue.

I have added you as a contributor on the stream, as well as Claire, but I can’t share the original file.

1 Like

Hi @bcall ,

Can you please share the stream with me so I can have a look?


Also, @bcall can you please tell us what type of elements are the affected ones? I tried on my end with some simple geometries and could not replicate :slight_smile: Maybe share a file with just one of two sample elements?

Alex, sure can! What is your email?

alex [at] :wink:


Thanks! Will look into it and keep you posted


Created an issue for this. We’ll keep you updated @bcall.

Awesome! Thank you so much! Do you need anything else from my end?

Today I was able to export a native CAD file out of Civil 3D into Speckle without any issues. However, when I tried to push a CAD file exported from Revit into Speckle from Civil3D, I had the same issue as above. I also noticed that when I loaded the CAD into Navisworks, exported out as an FBX and loaded that into Blender, it also gave some lines to the origin point, but didn’t create surfaces like the export from CAD does.


Finally got around to fixing this! The fix will be available with our 2.8 release :slight_smile:

For the curious, the glitch was a result of Autocad mesh face vertices sometimes having negative indices, which wasn’t being handled correctly in our conversion.


That is great news!! Thank you Claire and Speckle Team!