Attribute added to existing GH script does not appear in Power BI

Howdy. We’re using Speckle to go from Rhino (using Grasshopper) to Power BI. So far it’s been working very well.

Today I added a new attribute of textual data, called “BColor”, to the grasshopper component.

Upon sending, I can look at the model on the website, go to an object’s properties, and see the added attribute.

However, when I then bring the data in to Power BI and click on a “record” in the data column, the BColor field is not there.

I have tried completely starting over from scratch with a new Power BI document, and it still doesn’t work. Any help is greatly appreciated.

Thank you!

Here are the logs, first from the Manager2 folder:
SpeckleCoreLog20240104.txt (155.5 KB)
Then this log is from the RhinoRhino7 folder:
SpeckleCoreLog20240104.txt (70.0 KB)
There are no logs in the GrasshopperGrasshopper7 folder.

Hey there,
Can you please share the Speckle Model URL so i can try to reproduce the issue on my end?

Sorry, here you go:

Hey @CarlRTC ,

I have received the link you shared in Power BI and analyzed the data structure. Based on my observation, the BColor parameter is present in the object, but not all objects have the parameter set. For instance, in the image below, the Polyline does not have it. I added a new column and extracted the BColor field from the data record. I also replaced the Errors with RGB(0,0,0). I have attached the Power BI file for your reference. Please take a look:

8536.pbix (38.3 KB)

Please let me know if this resolves your issue.

Hi Bilal, now that BColor attribute has appeared. I don’t think I changed anything. I noticed I have to separately refresh the preview in the Transform data window, even after hitting Refresh in the main window. Maybe that has something to do with it.

In any case, thank you for your fast responses!

1 Like