Analytical Model elements cannot be send to Speckle

Hello Specklers,

to not mess up @chuongmeps post further with my topic, which goes in a similar direction …
Probem with complex family - Help - Speckle Community

It seems that the newest release candidate as well as version 2.9.3 are not able to send analytical model elements to Speckle (Revit 2022, before the big change of the analytical model in Revit 2023).

In my case, I don’t need it for a project, so we are not in a hurry :slight_smile: .


Problem maybe from this :

May be need Speckle team review first

1 Like

Hey folks, thanks for the report!
I just tried with rc4 and the sample structural model, and it seems to work fine, what selection method did you use?

For further reference, I’m testing again with 2.9.3 and Revit 2022.1.3. My procedure for the upload is to switch on all analytical categories and select all analytical objects → Sending only the selected analytical elements. This is a longer message and I hope it is helpful to you.

A. The simple architecture sample model of Revit
I tested this model by accident, as I thought it would be the one you chose.

  • 2 of 3 columns
    The L-shape steel profiles worked and are also visualized in the viewer. The circular concrete column was not transferred
  • 6 of 10 analytical walls
    the transfer was not complete


B. With the Model you have used (simple structural example model)
everything looks great

By comparing this transfer with the other cases your transport is perfectly calibrated.

C. With our test model
Physical geometry was transferred completely (see screenshot below), but the analytical one was not. It is a very tiny and simple model without any complexity.

As our model is based on our own template, it might not follow the “law of nature” of the classic Revit template. Maybe there is a specific setting/naming one has to consider in the template so that it works.
In case you want to test it with our model, I can send it to you via PM. Here is an overview that it only took the nodes and nothing else. It is also interesting, that it shows the German category name for the nodes … the model was initially created in the German language setting. Addendum: Did the German naming also for the physical model … might not be so interesting after all.

Thanks a lot Alex!
You pointed me in the right direction; it turns out the analytical members were suffering from a mild case of “missing null check”, and in the sample arch model they were missing some materials and other props the converter was expecting.

I’ve treated it with a light dose of specklicious drugs :speckle: , and everything seems to be coming through now: Speckle

I’ve also made a new rc5 with the fix, let us know how it goes (it’s building right now)!

1 Like

Lovely :slight_smile: … did the trick :muscle:. Thanks Matteo!!!

Everything except the curved beams went through :slight_smile: … but that is something for the next releases :slight_smile: