Accessing Revit Geometry inside Grasshopper

Hi All,

So I have a Speckle branch with Revit structural framing elements (Cables) sent to me by the structural consultant, everything looks good in the speckle viewer online but when I try receiving it in Grasshopper, it comes out as empty, is this a bug or structural framing isn’t supported?

Just to rule out Revit-Grasshopper transfer as the main issue, I tried receiving the elements in Revit as well but it was the same issue, it also came out with empty result.

Hey @a_m welcome to the forum, feel free to Introduce yourself :person_gesturing_ok: if you’d like.

My hunch is that you just need to expand the received object until you get to those elements to be able to see the geometry.

If you could share a portion of your model I’d be happy to investigate!

Thanks for your response @teocomi. The object is already being expanded without any luck, it still doesn’t output any object

Hey @a_m ,

You can see the structure of your data in our web viewer, or using the GH connector. Depending on the source application, the structure of the data may be more complicated than simple elements output. In your case, you are trying to access the geometry of Revit elements. As you know, Revit elements store much more than just simple geometry. So you need to Deconstruct the received data couple times. You can use Deconstruct Speckle Object node as many times as you like. Geometry you are trying to access will be stored under a key called displayValue.

The first elements output stores the Revit categories. Select your category and deconstruct, you’ll have access to individual elements.

If you still struggle with it, please share a link to the Speckle Model, so we can replicate it on our end and share the solution.


This solved the issue, thanks a lot.

1 Like