1. T0: Response status code does not indicate success: 405 (Not Allowed)

Hi all,

I ran into an issue with speckle 2 in grasshopper.

When I try to send an object to an existing or new stream (tried both) the sender component turns red and yields the following error message: “1. T0: Response status code does not indicate success: 405 (Not Allowed).”. Anyone an idea what that indicates?
I can select my account and I can see all streams wit stream list, but sending or receiving yields an error.

We also tried the following: my colleague created a stream with a simple cube. I can find the stream but just not receive the data, it yields the following message “1. R: Response status code does not indicate success: 504 (Gateway Time-out).” The reciever component does provide the info, just not the data.

Thank you in advance!

Kind regards,



Hi @Simon1! And welcome to the community!

It seems like the request is timing out before being able to finish. Are you using our public “speckle.xyz” server? If so, would it be possible to share with us the stream id so we can investigate further?

Anyway, thanks for reporting this! :slightly_smiling_face:

Hi Alan,

Thank you for your reply. We have a company server. So, I just tried to send the object to the speckel.xyz server and that works fine. Any idea why sending to the company server does not?

Hi @Simon1, not really. Unfortunately we can’t remote debug other people’s deployments without an enterprise agreement in place (we need to look at your infrastructure and access things that are best covered by an agreement for both party’s sake).

405 not allowed stands for the fact that the specific method - i suspect a POST request to the upload endpoint - is not allowed; this can be either (a) server is down, (b) nginx/proxy server misconfigs, or anything else in between.

Hi Dimitrie,

Ok, no problem. I will ask one of my collgeagues to look into this. If we can’t figure it out I’ll come back to you.


1 Like