Speckle Won't Receive or Send, Also Cannot Login/Logout

Hi, I am trying to run Speckle on Dynamo. It worked just fine last week but today, it absolutely refuses to work. I’ve uninstalled/reinstalled Dynamo and Speckle several times to no result.

Any interaction with Speckle nodes result in a “Null” output, Speckle doesn’t ask me to login and Speckle Accounts option under View in Dynamo is not there. I’ve tried to find if there is some residual files so i can delete them to have a clean uninstall but no luck. Any help is appreciated.

We’ll need to know:

  • dynamo version (be aware, we’ve had some reports that dynamo 2.0.0 doesn’t like speckle)
  • revit version
  • does it work in dynamo sandbox (no revit)?

Also, can you try with the latest pre-release?

Revit 2019.2, Dynamo 2.0.2, running on Revit.

Actually, I figured it out. We use AVAIL to manage content and it was a conflict with AVAIL. Thanks for getting back to me though.

1 Like

Ah, great to hear you sorted it out. Can you let me know what the conflict with Avail was? We’re trying to play nice, maybe it’s something we can fix on our end.

Not sure what exactly broke it but it basically completely broke speckle. I’ve also noticed not only Speckle started working, Dynamo performance improved quite a bit once I disabled the addin. This isn’t the first time AVAIL had issues with Dynamo so it might not even be because of Speckle.

Okay, gotcha. Thanks for this! I thought there might be issues with some of our dependencies and conflicting libraries… but it sounds like we can safely blame AVAIL for now :smiley:

1 Like