Speckle - Revit v2.5.2 error receiving files


Recently I updated all the Speckle add-ins to v2.5.2.
incl the Speckle-Grasshopper and Speckl-Revit addin.

Unfortunately I noticed, when I send data from Grasshopper to Revit it does not ‘receive’ the data (the blue circle is endlessly turning round). While with the old version v2.2. it was working fine.

It looks like the data is send correctly to the speckle environment, see figure below (just a few columns).

However when clicking on the ‘receive’ button the data in Revit the ‘blue circle’ keeps on turning (while no data in Revit pops-up.

Any suggestion, what the cause is and how to overcome?


Thanks :slight_smile:

btw, is there an option to temporarly go back to an older version of the add-in?

Oh no, can you please share a sample stream with this issue? We cannot replicate it internally :confused:

If you have the latest Manager you’ll be able to easily downgrade any connector from the dropdown next to the install button:

1 Like


Thanks for your quick response!
See attached, the GH creating the stream.
2022-04-29 Speckle v2.5.2 example error.gh (10.6 KB)

I noticed in Revit2021 when opening the Speckle tab, I get the following error:


maybe it has something to do with it?

  • if I click ok, it terminates Revit.
  • If I ignore it, speckle seems to work until I click the ‘receive’ button, there is nothing received…

Just for my understanding of the versions correctly. I noticed the Revit en Grasshopper version naming-history is not exactly the same. Is it important to have exactly the same GH en Revit speckle version installed? (e.g. v2.2.10.173 GH and v2.2.10.173 Revit) or are the plugin seperate usable?


Ok so, I tried in Revit 2022 and everything works well, as soon as I get to my desktop I can try in 2021 too.
But given your error messages, I would assume maybe something’s borked in your local setup.
Could you please:

  • ensure all software using Spekcle are closed (maybe with a reboot)
  • reinstall the Revit connector to the lastest stable
  • reinstall the Dynamo connector to the lastest stable (if you have it installed)

In regards to versioning, here’s how it works: speckle-docs/connectors.md at main · specklesystems/speckle-docs · GitHub (sorry our docs auto-build is temporarily broken)

So just make sure the first two numbers are aligned across connectors and everything should work!


Thanks for your advice.
After downgreading to Speckle 2.2. it worked fine again.

Hereafter upgreaded to speckle 2.5 again. (with reboot)
Hereafter, every time I click in Revit on the ‘speckle tab’ → Revit connector, I get the error message shown below.
So unfortunately it has most likely to do something with speckle 2.5?

Did Revit 2021 in combination with speckle 2.5 work on your pc?

Thanks again :slight_smile:


Just tried now and all seems OK on my end :confused:
Maybe there’s a conflict with another plugin you have installed? Are you able to disable the other plugins temporarily?