Speckle Manager not updating

Hi guys

I am having a problem here. Today I opened my Speckle Manager to download a connector and got notified by an update.

The download starts automatically, it finishes, the Speckle Manager gets closed promising that the updater will start but it doesn’t.

I am using the manager from a windows user without admin privileges. Btw, when I use a user account with admin privileges the update works just fine.

I don’t think our manager requires admin priviliges. Did you try closing manager from taskbar and do it again? I’ll ping the father of our Manager @teocomi

Correct, no admin privileges should be needed…
Have you tried restarting your machine? Maybe some processes preventing a correct installation are running…?

Had a similar issue today - downloaded the manager from my speckle.xyz home page (just made my account), installed, upon opening the manager was immediately notified that a new version is out, installed that, manager refused to start from then on. Solution was to uninstall everything, download from here, then it worked for some reason.

Thanks for the report Grub, made me realize that the link in the frontend is actually outdated, we are fixing it :slight_smile:

In case anyone is running into similar issues, our downloads page contains the most up-to-date versions of Manager:

Reinstalling the manager worked. I’ll let you know if something comes up on the next update. :slight_smile:


A post was split to a new topic: Issue sending from AutoCAD to Revit

Hey! FYI as the Manager 2.3.18 comes out we faced the same issue. The manager automatically triggers the update, closes it self promising that will launch the updater but nothing happens. Downloading the latest installer from the releases page and reinstalling works, but does not feel ~great~, if you know what I mean. :confused:

Hey @vwb could you check if maybe your antivirus is blocking the automatic execution of the new version?
We’ll look into an alternative mechanism in the meantime!