RevitWall component - wall not on correct place


When trying to send a wall geometry to Revit, I noticed the following:

The location of the wall in Rhino:
Bottom of wall; Z=0
Top of wall; Z=3000mm
20m long

Level FFL00 = 0mm
Level FF01 = 5000mm

However, after ‘Receiving’ the wall component in Revit;

-The wall is placed on -4000mm below level FFL00… (wrong Z-location)
-Furthermore the Top Constraint is given as: ‘Up to level: SHLSL’ (I don’t have a clue what this level is). I think this should be ‘unconnected’ (base offset is given and from there the geometry is draw.

2022-02-13 Revit Wall wrong (18.0 KB)


  1. Any Idea why the wall is placed here in Revit at -4000. (I expected that the ‘Surface/Wall’ would be placed exactly on the Z-level in Rhino, because the boundary lines of the surface are the input for the wall component…)

  2. Is there an option to ‘overwrite’ the ‘Baseline Offset’ = 0 and ‘Top Constraint’ = unconnected?
    I tried to do this by adding the parameter component, but If I do I get the following error:

Any suggestions how to overcome?

Thanks again :slight_smile:

Desired Reult:

Hi again :slight_smile:

Thanks for helping us improve Speckle! I just tried with the sample GH file provided and I’m getting a different result in Revit 2022 and a default template:

Can you please confirm:

  • Revit version
  • Connector version
  • What Revit template are you using? Maybe send us a copy too if possible!

Ahh hmm that’s interesting…
Looks like its working on your pc. So it has probably to do something with the template…

Although I still find it quite strange because the floors and framing are placed correctly, (only the walls are not…)
Any suggestion where to look in the template? / what could cause the issue?
I am very sorry but I think am am not allowed to share our template.
Would it be possible to share the 'default template? This way I can trouble shoot a bit :slight_smile:

Currently using:
Revit 2021
Speckle manager v2.1.18
Grasshopper, Revit, Rhino connectors, all 2.3.0

Thanks again!

Surely, here is the default template in 2022:

DefaultMetric.rte (5.1 MB)

Let me know what you find out!


Ahh thanks!
Sorry for this rooky question but I am not an Revit expert :see_no_evil: (only GH).
I cant open the template because it was last saved in Revit2022.
Is there an option to save it in an ‘older’ version?

Thanks again!

That’d be too easy! Hehe, anyways I managed to get a 2121 version, here it is!
DefaultMetric.rte (5.1 MB)

1 Like

Hi @teocomi!

I came across this topic when I experienced a similar issue and I saw it wasn’t solved yet.

In GH there are now four different options to create Speckle RevitWall objects:

  1. by curve and height
  2. by curve and levels
  3. by profile
  4. by face

I’ve tested all 4 options, but only at the third option I get the same issue as @GH007 described: the wall is not placed at the correct height. I’ve tried our company templates as well as the templates you provided in both Revit 2021 and Revit 2022.

The GH script references a RevitLevel by name, which is used as input for the wall objects. The GH geometry has random locations and dimensions. Below some screenshots of the different parts of the workflow:

2022-03-22 16_52_52-Commit _ Speckle

I’m curious what’s causing the issue here. Could you have a look? Here’s also the GH script I used: (58.6 KB)

I currently use the latest connectors and manager available:

  • Speckle Manager v2.1.26
  • GH connector 2.4.2
  • Revit connector 2.4.0

Thanks in advance!


Hey @GerranLankhorst ,

Thanks, for the super complete bug report! We’ll definitely investigate.
Tracked it here: Revit wall by profile wrong elevation · Issue #1131 · specklesystems/speckle-sharp · GitHub

Hey there!

Apologies it took us a while to get to this one, I think I’ve fixed it - we were not computing and applying an offset in the case of a profile wall (something that Revit does “automatically” for the other types of walls).

I can make a beta release if you’d like to test it quickly otherwise it’ll be included in the next release :slight_smile:

1 Like

Thanks, nice work! Don’t bother making just a beta release for just this issue. But if some more will be included I’m definitely interested!

1 Like