Parameter Value in Power BI is not the same value in Revit

Hello friends, make a comparison of the information exported from revit to power bi using speckle and verify that the information does not match, such as for example: the area of revit is 27.04 m2 and in the breakdown of information in power bi it is 87.71 m2, i look forward to your help. thank you.
Saludos desde Perú.

Hey @joel_balvin ,

Welcome to the community! Feel free to Introduce yourself :person_gesturing_ok: to the community if you want to! :grinning:

I’m sorry to hear that something is not working as expected. Could you please provide some more information? It would be really helpful if you could share screenshots of the specific element and parameter in both Revit and Speckle. Additionally, providing the URL of the Speckle model would allow us to reproduce the issue and find a solution.

Hello, as I mentioned, the information in the HOST_AREA_COMPUTED parameter is incorrect according to the Revit information, however I found the real area which is in the “materialQuantities” parameter.

It’s great to hear that you found the value you were looking for! Could you still share the Speckle Model URL with me? I want to ensure that our conversions from Revit are correct.


The other question I have is because the model appears dark planes to me.

I guess that happens when a tab is open for too long. You need to refrest the page.

I haven’t been able to reproduce this. I sent a 1x1 floor and its area is 1 square meter. Can you share the Revit file too?

EJEMPLO 01.rvt (4.6 MB)

It is a random example model, I await your prompt response

A post was split to a new topic: How to extract value from Power BI list?

Thanks for sharing the file. I did send it to Speckle but I am unable to reproduce your issue. Parameter value is correct on my end.

I will be doing something wrong

Thanks a lot for sharing the screen recording with me. I’ll take a closer look into this issue as it seems a bit unexpected.

I tried to recreate the issue you were having by following the steps you provided in the screen recording, but I couldn’t seem to replicate the problem. I even changed the language setting in Revit to Spanish to see if it was a localization issue, but it seemed to work just fine. The only other thing I can think of is that the issue might be related to the version of Revit you are using. If it’s not too much trouble, could you please let me know which version of Revit you’re currently using? Additionally, have you tried sending the file from a newer version of Revit? If you have and you’re still facing the same problem, please do let me know!

Hello, indeed
I was able to achieve it with an update of Revit 2022, the one I had was Revit 2020 that’s why the incompatibility,
thank you so much

1 Like

4 posts were split to a new topic: Revit Parts Quantities Exceeds Actual Total in Power BI