Issue sending large Rhino model to server

Hi Dimitri/Matteo/Cristi,

I have a Rhino model containing 17411 closed polysurfaces and would like to send it to our Speckle server, but so far I have only been successful in sending small amounts of from this model. When attempting to send a selection of 1763 objects through the Rhino connector, Rhino crashes. When I do the same in grasshopper, the conversion begins but then interrupts about halfway through and provides the error message “T0: One or more errors occurred.” The same message appears in the Rhino send report.

I have tried this on 2 different servers and tested with 2 other models but still no luck. Any thoughts on what could be causing this or how I could do to fix it?

I am running Rhino 7 SR14 with Rhino connector v.2.4.0, Grasshopper connector v.2.3.0 and SpeckleManager v2.1.25. The model is in millimeters, measures about 45000W x 56000L x 80000H and is located roughly 65700 from the origin.

Any support on this would be very much appreciated.


Hi @simonymous! Does this happen with our server at as well? If yes, we’d really want to look into this - can you by any chance share that model (in private) with us, or a similar model that we could reproduce with? If no, it might be a more hairy deployment issue on your end :grimacing:


Hi Dimitrie! Thank you for your prompt reply, I’ll send you a private message with more details.

1 Like