Grasshopper Send Error "T0: One or more errors occurred"

Hi all,

I’m very new to speckle but I’m currently having issues with the GH Speckle Send node. I’m trying to send a list of points to my speckle stream but no matter how I connect it I always receive the error code “T0: One or more errors occurred.”

I’ve tried to either connect the points to the Send node directly or tried to connect the points into a create speckle object node then connecting this to the send node, but it always has the same error code.

Any advice on this would be greatly appreciated.

1 Like

Hi @Holly! Welcome to the forum, and sorry for the late reply. Several questions:

  • which server are you using?
  • what version of the connectors?
  • screenshot of the definition!

@AlanRynne might have extra questions to follow up afterwards. Sounds like an easy one, hopefully we’ll nail it soon!

1 Like

Hi Dimitrie, thanks for getting back to me!

I’m using v2.6.3 of the Grasshopper connector. I’m just on the standard speckle server, as far as I’m aware as I haven’t set one up.

I unfortunately can’t screenshot all of my workflow but to give general context, I’ve created various lists of points which I have been trying to feed individually into the Data input of the Send node. I’ve attached an image of just the final part of one of these as an example.


1 Like

Hey @Holly, thanks for getting back to us.

Not really sure what could be going on there. could you send me your ‘SUUID’ so we can pinpoint your errors in our logging platform? You can find it in the Speckle Manager → Settings; it’s the last item on the settings page.

As for the workflow, could you try and reproduce this error in a file that you could share? Usually, we don’t really need the entire GH definition, just the data you are trying to send or an equivalent set of geometries that will reproduce the issue.

I also have a couple follow-up questions for you:

  • Does this happen regardless of the input you try to send? i.e.: if you send a single sphere or a box do you get the same issue?
  • Do you have any other connectors installed? if so, which ones and which versions?
  • How big/long are those lists of points you are trying to send?
1 Like

Hi Alan,

I have 6 connectors on my device: Dynamo, Revit, GH, Rhino, Excel and SAP2000, all on the newest versions.

My SUUID is a8f13691-2fc3-4a4e-bf00-54a8bed4d5ea

The error seems to happen no matter what I try to send. I’ve tried sending just one value and similar small pieces of data but still receive the error message.

I’ve included another screenshot using panels to show the inputs before the divide by length node. The geometry I’m working with at the moment is all fairly simple, the lists are all only around 6 to 10 points each.


1 Like