Can't load a stream to the speckle connector in QGIS

Hi there, I am sending some geometry from QGIS to Grasshopper.
The whole process was straight forward but now something broke and I can’t load a stream to the connector in QGIS. I tried to reinstall the connector but nothing.
Here the error message:

1 Like

Hi @GabrielGarcia

thanks for reaching out to report this! And sorry for the inconvenience!

Would it be possible for you to share the file where this happens so we could try to reproduce on our end?

It happens with all projects. even with a blank one (see attached video)
In my opinion it is not project related.
BTW, I am using QGIS 3.22.1

1 Like

I’ll do some testing to try and reproduce your issue with the exact version and will get back to you shortly :wink:

Hi @GabrielGarcia ! I have installed the 3.22.1 version and tried to reproduce the error. It generally indicates that selected stream cannot be accessed - either some of the streams saved in the project, or the new one you are trying to add. I could reproduce only when I intentionally delete the stream right before clicking OK in the popup window.

To check if there are and invalid streams saved, you can click Plugins-> Python console and run this:

pr = QgsProject.instance()
saved_streams = pr.readEntry("speckle-qgis", "project_streams", "")

May I ask if the error shows up only with this particular stream or with others too? If it used to work at some point and then broke, what changed before it broke? If you don’t mind, you can PM me to add me as a stream collaborator, and I will test again on my side.