Archicad connector error - WebSocketException


I keep getting WebSocketErrors when tryin to upload a model to a Speckle stream. Thing is, i managed to upload a bunch of versions of it before, that were either missing some categories or some objects were locked and didnt go through. So it worked a bunch of times but then all of a sudden it just broke and cannot upload to this stream, even after computer restart. Tried uploading to a new stream and it worked fine so I’m guessing the original stream just broke somehow?


Hey Andrei, thanks for reporting this!
Sounds quite weird. Could you please tell us:

  • version of the Archicad connector
  • if you are using the XYZ server or another one
  • if you can send to that stream from any other connector (if you have any installed)

And we’ll look into it!


  1. Good question. The Speckle for Archicad windows sais v2.8.0 but the Speckle Manager in Tray sais 2.9.3 successfully installed so…
  2. Im using a private server
  3. Tested and successfully sent from Rhino. Rhino Connector version is 2.9.3 which matches what is displayed in the Speckle manager, unlike Archicad. So i think this might be a big clue then. Archicad is somehow booting up a previous version of the connector? Still weird that it did work several times before gettin perma locked out.

Thanks! Regarding the version mismatch, you could try:

  • uninstalling & reinstalling the connector
  • check under programs and features in case there is an old version that maybe wasn’t removed successfully


Regarding the WebSocketErrors, it could indeed be due to your local server set up, and in that case it would be really difficult for us to debug. If you get to replicate it on XYZ let us know and we’d be happy to investigate further :slight_smile: